Jeep Grand Cherokee Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello from North Mississippi,

New to this forum but I've been around a few others. I am currently having problems with my 98 zj. I have the infamous lighting issue, no running lights. I have headlights, signals, and brakes, but no tail lights, marker lights, dash lights, fog lights, or trailer lights (when hooked up). I have checked the fuse box (inside and out) had the dash apart several times (no broken/frayed wires) checked the switch, and all connections. I am getting power to the sockets, which makes me think its a ground, but I can't find where the ground is for them and I cant seem to find any solid information on this issue, even though everyone has seemed to have it at some point or another. Just looking for advice and a possible solution.
 

·
Registered
Joined
·
4 Posts
Hello from North Mississippi,

New to this forum but I've been around a few others. I am currently having problems with my 98 zj. I have the infamous lighting issue, no running lights. I have headlights, signals, and brakes, but no tail lights, marker lights, dash lights, fog lights, or trailer lights (when hooked up). I have checked the fuse box (inside and out) had the dash apart several times (no broken/frayed wires) checked the switch, and all connections. I am getting power to the sockets, which makes me think its a ground, but I can't find where the ground is for them and I cant seem to find any solid information on this issue, even though everyone has seemed to have it at some point or another. Just looking for advice and a possible solution.
Following. I’m having the same issue in my 96
 
1 - 4 of 4 Posts
Top