Jeep Grand Cherokee Forum banner

1 - 20 of 4822 Posts

·
Registered
Joined
·
3,694 Posts
Discussion Starter #1
Starting this back up, the other got out of hand fast with bickering, wont happen again, let's keep this one on topic.

Today I am doing the TJ gas bezel mod,draining tranny fluid and filling her back up, wiring some lights on back of my rack, and just doing a general check of everything to make sure everything is tightened and where it should be.

I'll post pictures tonight!
 

·
Registered
Joined
·
1,505 Posts
Well I didn't do it but my Jeep did it self. It is running like #2. Smells really rich and stumbles when you let of the gas. If you have it in P or N and Rev it up 2K or more and let of the gas it dies. 1 time it did die and restart itself. Just went out and started her back up. Some quick hits of the gas up to 1K RPM's and it drops down to almost dieing. The Volt meter is also dropping to when the rpm's drop. It has to be something fuel or air related. It seems air to me because when it first started to do it smelt really rich, but it doesn't any more.
 

·
Registered
Joined
·
266 Posts
Put a T on your fuel line and check pressure, sounds like fuel pump. Had this happen, same symptons, on my ZJ before. You should have 39 pounds with the ignition in the on position. Good luck. Also check the cat for ceramic breakage, could be totally clogged. Good luck.
 

·
Registered
Joined
·
1,505 Posts
hellride1975 said:
Put a T on your fuel line and check pressure, sounds like fuel pump. Had this happen, same symptons, on my ZJ before. You should have 39 pounds with the ignition in the on position. Good luck. Also check the cat for ceramic breakage, could be totally clogged. Good luck.
Yeah I'm bringing it to my mechanic tomarrow, as I live in an apartment and can't wrench here. How hard is it to replace the pump?
 

·
Registered
Joined
·
266 Posts
Not hard, more time consuming. Need line wrenches, take off tank straps( and skid plate), drain tank, replace, put back together. Not that bad, just a boring job. Sucks.
 

·
Registered
Joined
·
1,505 Posts
Well I can't do it where Im at...no tools and an apartment. So it would have to be done at my mechanics. I'm hoping it is the PCV valve...but if it is the fuel pump how much would that run to get fixed at a shop?
 

·
YETI - The Abominable WJ
Joined
·
3,762 Posts
Picked up a K&N for the 99 for $15. A friend built an intake for his and sold me his old filter.

Spend the rest of the day tighening parts in the front end trying to find the pop. Changed the oil, replaced a brake light, replaced both license plate lights...Need to get things ready for Thanksgiving, want to go wheeling.
 

·
Registered
Joined
·
266 Posts
No clue what shop time is costing you per hour, but you can get oem pumps for about 100.00 to 120.00. I would say a mechanic will charge you about 275.00 to do it, maybe 300.00. Kinda expensive. Labor rate varies from shop to shop, no clue what yours would be or what the book calls for shop time for this particular job.
 

·
Registered
Joined
·
1,505 Posts
hellride1975 said:
No clue what shop time is costing you per hour, but you can get oem pumps for about 100.00 to 120.00. I would say a mechanic will charge you about 275.00 to do it, maybe 300.00. Kinda expensive. Labor rate varies from shop to shop, no clue what yours would be or what the book calls for shop time for this particular job.
Yeah I forget what they charge, but they do awesome work. I wish I didn't live so far away from my help. So 400 is ball park range? I can afford that but darn bad time for this to happen. I guess the good thing is that my skid plate is already off because I have to drill out a couple holes on my TR bumper to make it fit again.
 

·
Registered
Joined
·
266 Posts
Autozone's price is 128.00 using old stainer from bad pump. 200.00 for new pump and new strainer(bootie).
 

·
Registered
Joined
·
1,505 Posts
I know he uses NAPA and they have the pump and strainer for 130. They also have what they say Actual OE part, which is only the pump for 206
 

·
Registered
Joined
·
266 Posts
Good luck man, hope it is pvc or 02 sensor or something cheap. Any check engine lights????
 

·
Registered
Joined
·
1,505 Posts
No check engine lights...so that ruled out the 02 sensor for me. I was so looking forward to driving her to my parents house on Tuesday to get some comparison shots between my step-dads stock GC to mine. But looks like I might have to the GF's car. Still need to get my tire plugged too. Yeah Im definetly hoping for the valve. Im taking her in tomarrow on my lunch break from work.

Im also thinking it might be the Valve cause it drives fine, no issues when on the gas, but only when I get off the gas, but the RPMs get back to normal after a sec of it stumbling.
 

·
Registered
Joined
·
266 Posts
Oh yeah, forgot to mention open loop mode on 02 sensors. Unplug front o2 on downpipe, and then 02's on cat. This takes the computer to open loop mode, will run fine with all 02's unplugged. If it is an 02 sensor, this will tell you. If it runs fine with 02's unplugged, then you know your problem. I have had 02's go bad with no check engine light. Has your jeep been in deep water lately??? Might try it, takes about 5 minutes and might save you some money.
 
1 - 20 of 4822 Posts
Top