Jeep Grand Cherokee Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Gentlemen,

I have had a problem with my 2004 GC that even has the Dealership baffled and not able to fix.

The problem is that when shifting from Fulltime 4X4 to 2WD, the transfer case hangs up in Part Time 4X4. The only way to get it out of PT is to stop and back up the Jeep. Then it will go into 2WD. However now in 2WD the front differential is very noisy as I believe it is still coupled to the drive system and receiving power.

Some history,
The Jeep has 215K on it. It has no rust and even has the original exhaust. It is parked in a heated garage.
The dealer first noticed that there was metal in the TC and front diff and replaced both. The problem did not go away.
The dealer then replaced the linkage, again the problem did not go away.
The dealer then removed the front drive shaft and sent me on my way as they trouble shot the problem.
Again, the dealer replaced the TC and told me the problem was fix. I took them out in the parking lot and demonstrated that not only was the Jeep in PT 4X4 but there is a several noise coming from the rear diff when you turn the Jeep full lock-to-lock in 2WD or 4WD.
The dealer want to look at the Jeep again, but I have told them I’m gonna do some research on the problem on the Web, hence I’m here

Can anyone help me?

Thank you

Paul
765-490-0063
 

·
Registered
Joined
·
4 Posts
Noisy is of concern. Older 4x4 Ford Rangers and Toyota's required stopping and reversing to unlock 4 wheel drive. Really old tech involved turning the front lock hubs to engage or disengage. Those also suggested running with hubs locked to lube systems if not used frequently, times change.

It sounds like your rig is trying to disengage but hubs remain locked creating drag and noise. Not sure why rear diff should be noisy though. Additionally, When I first looked at buying a GC, I did research and was told to pay attention to the CV's as these could go bad and were easily overlooked. I know a bad u-joint will make a racket, I imgine bad CV would be just as loud. Double check the VIN for stock build and make sure they did not put in a different ratio when they replaced the front diff. Another question, any aftermarket lockers?
 

·
Moderator
Joined
·
521 Posts
could be failed bushes on the shifter lever pivot and linkage so it is not giving a full movement due to shaft free play.
if it has a CV type front prop it might be a case of the front axle is too close to the transfer box causing binding, and will happen more if lifted or after marker arms fitted or bushes are worn.
if you have a disconnecting type front axle then it could be a vacuum leak or hole in a vacuum pipe.
had a grinding/bearing noise from my front D30 on my ZJ (4.0 with 249 transfer) causing the brakes to grab at times and in the end traced it to 1 failed set of needle bearings in the front prop shaft cardigan joint, and only effected the drive when accelerating but would cause the n/s/front brake to lock when turning left on a damp corner
 
1 - 3 of 3 Posts
Top