Jeep Grand Cherokee Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
This maybe long but stay with me because I'm at wits end!

2001 Grand Cherokee Laredo, 4.0 IL-6, no mods..

Four days ago, I filled the tank up and the very next day started all my headaches. My wife was driving my Jeep, (I know bad call), and it stalled on her twice, she was able to restart both times instantly with no trouble. The next day we drove the vehicle for more than half a day with no troubles then it shut off while driving and I kicked it into neutral and restarted no problem. 1/2 mile later it cut off again and I was dead on the side of the road, all crank no kick. Had it towed to my local Pepboys, dropped the truck called a buddy of mine over to look at it and it started up and ran like I was an idiot. Decided to drive it home and about 2mi. down the road shut off and same thing all crank and no kick. it sat in the drive two days

Two days ago, drove it all around no problems, bought it to couple of buddies of mine and again no problems. Ran it for about two hours and it finally kicked off. Sprayed some starter fluid in and it kick right on, but stalled out almost instantly. Was able to start it no problem from that point on with starter fluid, but it doesn't keep.

Today, we replaced the fuel pump and assembly. Now it kicks on, no problems at all. But still stalls after about 5mins. The truck tries to rev itself up to maintain idle but eventually dies. You can feel the ASD and Fuel Pump relay clicking right before ti shuts down.

And thats where I'm at no. ANY thoughts, please shoot them my way. I'm this close from a match and the spilled gas!
 

·
Registered
Joined
·
183 Posts
but did they replace that relay? if not they could have thought the old one was fine and just threw it on im just saying lol
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Whole reason I'm on this blog is because I don't have the faintest clue what it could be. So I'm going to try almost anything thats suggested and I appreciate people taking the time out to try to help. Quick question though, if it was the neutral safety switch, shouldn't I be dead in the water. Right now I can start the truck no problems. It just won't stay on.
 

·
Registered
Joined
·
186 Posts
Check your coil packs. I had a similar problem on my 99. I could drive it for a while then it would die. Let it sit for a min and started up fine, would then die again anywhere between 2 min and a couple days. Took it to the shop and it was my coil packs.
 
1 - 12 of 12 Posts
Top