Jeep Grand Cherokee Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hello to all, I live in Italy and recently I bought a 1993, 5.2 JGC, now I have a problem with automatic: usually, if I'm right, the automatic do not shift to overdrive if the engine is cool; from two days my automatic do not shift to overdrive EVERYTIME! Is there someone able to help me? I hope yes, in Italy is absolutely too expensive to rebuilt an Automatic, and there are only three Companies able to do it. I hope this is an electronic problem.
 

·
Registered
Joined
·
4 Posts
Hi Luca, I live in Italy too...

first of all check the oil level in your automatic, according the specs on your owner's manual.

In a second stage, check for the pressure sensor.

I have a '93 ZJ 4.0 l, so my gearbox is all mechanical ( hydraulic... ;-) ), no electronics!

Best Regards

[email protected]
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Ciao Picatrix,

I did some checks, it seems a failure of the transmission. I'll have to rebuilt it, or to buy a new trans :-((
So also you live in Italy, where? I live near Milano.
 

·
Registered
Joined
·
4 Posts
Hi Luca...

I'm wondering how many miles/Km you have in your trans...and I start to worry about mine :-( .

By the way, I live in Romagna.


Best Regards
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
Hi picatrix, don't worry about miles, till 2 months ago I owned a XY, the "small Cherokee" with 6L 4.0 litres and 230.000 Kilometres on the odometer, the Auto-trans worked still good, and should be the same transmission of yours! On this "new" Grand Cherokee I have only 73.000 miles,but none changed the oil before..........
 

·
Registered
Joined
·
4 Posts
I had 120.000 km on mine ZJ;
when I bought on February 2001 there was only 80.000, because I use it for working and I usually drive it at least for 100 km on highway per day (it runs on CNG ;-) !!!).
My local Chrisler/Jeep dealer ,who sold it, made me pay an extra 2.000.000 Lit for various control...but when I checked all the transmission line fluids at 100.000 km (auto, transfer case, differentials) I discovered they were "all original": 1993 fluids, I suppose, dark, smelly & as viscous as fresh water :-( !!!

Best Regards

[email protected]




<font size=-1>[ This Message was edited by: picatrix99 on 2002-04-03 09:02 ]</font>

<font size=-1>[ This Message was edited by: picatrix99 on 2002-04-06 05:39 ]</font>
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #7 ·
I understand, but my experience in that automatic is good, and hope the same for you, in your auto there isn't too many electronics; by the way remember to check oil level every 1000 KM. In my trans the oil was not only "old" but also the level was too low, when I bought the GrandC, I had to add 2 litres to come home, fortunately I checked it immediately! but the problem I have now, after 2 months and 4000 KM may be because of that.
 
1 - 7 of 7 Posts
Top