Jeep Grand Cherokee Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Long time viewer, first time poster..
I have an issue where the volume for the navigation will not go above 25.. The max is 32 I believe. I like it loud, due to wind noise and the radio. Last week I was on a phone call and must have disconnected the phone before actually ending the call. This created about 45 minutes of WTF!!
The instrumentation cluster stayed on displaying the press brake and push the start/stop and the radio wouldn't shut off. Weird right? So after a searching around I found out if you mad another call and ended it properly it would resolve the issue and then the instrumentation panel and radio would shut down like normal. I was happy it worked, however since that day the navigation volume will not go past 25. I'm not that old, but I like to be able to hear my navigation over the road noise.
So I am hoping that one of you may have experienced this and can help me out. I appreciate you guys!
Things I have tried..
resetting the unit back to factory settings.. It didn't really do anything at all.
I've unpaired and repaired my iPhone.

I hope someone has experienced this and are able to help me out..
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
That's weird. Have you tried going to your dealer to have it checked?
Yeah I took it to the dealer and they said the radio was a couple of revisions down. So they fixed that, but it didn't fix the issue. I was thinking about disconnecting the battery for a few and then hook it back up. Wondering if that may clear some sort of cache in the system that may be corrupted. Thoughts? Not sure if it will work.
 
1 - 3 of 3 Posts
Top