Jeep Grand Cherokee Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I have a 2000 wj limited with a very mysterious stalling issue. It runs about 10-20 minutes, then stalls like somebody switched off the key. After, the sentry key light comes on,:confused: and the gas guage wont move, crank the key, and it sounds like it's not firing, or getting fuel, like a computer issue. If I remove the battery cables and let it sit about 10 minutes sometimes it will fire up, sometimes not. Yesterday I did a few things, 1 removed the battery terminals and cleaned them until shiny, 2 removed the ecm terminals and cleaned them with electrical contact cleaner, 3 removed the old crankshaft position sensor and replaced it with a new one, 4 removed and cleaned the two sensors in the side of the throttle body. When I was finished it fired right up, I drove it a short distance, then let it idle 45 minutes, no stallout, then today 20 minutes away from home it stalled, then two more times on the way back....:confused: I have read many of the threads posted here, many sound the same as mine, but I could really use some advice, thanks,
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Mysterious stalling issue ...help!

No the cat isn't clogged, it has alot of power when it's running, and no check engine light or codes. Today I replaced the relay for the auto shutdown thinking it was only that, no luck. Then when it stalled again I shook the right side connector on the pcm while my wife cranked the key, and it fired right up. 5 minutes later it stalled again, I shook the connector again and it fired up again. So now I'm thinking it's that connector. Any suggestions?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
Mysterious Stalling Issue...Help

So today on Saturday I did another visual inspection on all of the wiring harnesses that I could see, with no evidence of a burnt or rubbed section causing a short. Then I took my wj to the local garage to have the battery checked, the tech said it was low on charge, but good, then he put a charger on it for 15 minutes and retested it. The battery turns out to be aok. The alternator was also checked and is running good even under a load, (lights, a/c, radio, wipers). So now I really don't know. I'm really stumped. Order a PCM, or not???
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
I installed a remanned PCM today 10/24/2013, and my cherokee is running like new again. I went with All Computer Resources. They flashed the new one for me and everything. Also I bought an ELM327 Bluetooth OBDII Reader and can monitor all the paramiters of the diagnostic system with an app called TORQUE. (ANDROID)
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
So I have driven 300 miles with the new PCM in my WJ, and had a smog test done for my registration renewal. No problems, no codes, good mileage, and the thing is running like new! So to anybody else out there thinking of trying all the quick fixes to stop the "mysterious wj stalling problem" try replacing the PCM and go from there, it will save you money, and headaches...Also, if you want to really see what your sensors and pcm are doing, buy an ELM327 Bluetooth OBD2 Adapter (found on EBAY) and the Android Torque Pro App. With these you can monitor all of the sensors, voltage, temp, among other cool things. The app has a logging feature, a code check, readiness check and will let you know more than the guy at the stealership is going to tell you! It's really worth $20!! HAVE FUN OUT THERE, Don't JUST EMPTY EVERY POCKET!
 

·
Premium Member
Joined
·
560 Posts
Glad to hear its all fixed up! Thanks for reporting back! :)
 

·
Premium Member
Joined
·
560 Posts
Just to help out any others who may be experiencing this issue and the PCM isn't it....I had the same problem with sudden stalls that seem to come out of no where and it turned out to be my spark plugs. They were NGK Iridiums and were not that badly worn. I switched them out with the OEM copper champions and it stopped stalling immediately. Only OEM plugs for me for now on!
 

·
Registered
Joined
·
1 Posts
same issues with my 98

my issues just started this week, 4.0 6cyl runs for a while then dies, sometimes fires back up sometimes takes a few min. then bucks and jerks and repeatedly dies. So guess I start the process of what is it.
 
1 - 9 of 9 Posts
Top