Jeep Grand Cherokee Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Yes, I am an idiot and I purchased a stage 2 Jet module for my 4.0L 1995 ZJ. After I finally got the thing installed (the coolant reservoir would not fit back after the module was installed) as well as the low-temp stat, I drove it (with premium fuel) for about 250 miles and noticed no increase in power and worse fuel mileage. To make matters worse, after I uninstalled it, the engine runs rough and still gets poor mileage. I thought maybe it darnaged the computer or the O2 sensors or something, but the "check engine" light is not on. Any thoughts or ideas on this? Do I need a tuneup or something now? I thought about having a diagnostic done, but that seems like a waste of money if the check engine light is not on....

_________________
1995 4.0L ZJ Laredo, Rusty's BB, 15x8 Rockcrawlers, 30" Bridgestone Dueler AT's, Rusty's airtube and 6x9 K&N cone filter, Flowmaster and 2.5" pipe, with addtional 3" Rusty's lift and 31" BFG's on the way!

<font size=-1>[ This Message was edited by: Nullnlloyd on 2002-02-12 13:47 ]</font>
 

·
Registered
Joined
·
69 Posts
First of all... if memory serves. The stage-2 also requires a free flow exhaust and K&N air filter. it *might* have required more, like an upgraded intake or cam. You probably really want the stage-1 chip if you at the very least don't have the exhaust.

As far as putting the stock chip back in. you might try disconnecting the battery for an hour or so. force the computer to forget everything it might have picked up from the stage-2. and let it relearn the stock chip. But don't hold me to that or blame me if it causes other problems. It's only a guess.

On 2002-02-08 16:04, Nullnlloyd wrote:
Yes, I am an idiot and I purchased a stage 2 Jet module for my 4.0L 1995 ZJ. After I finally got the thing installed (the coolant reservoir would not fit back after the module was installed) as well as the low-temp stat, I drove it (with premium fuel) for about 250 miles and noticed no increase in power and worse fuel mileage. To make matters worse, after I uninstalled it, the engine runs rough and still gets crudpy mileage. I thought maybe it darnaged the computer or the O2 sensors or something, but the "check engine" light is not on. Any thoughts or ideas on this? Do I need a tuneup or something now? I thought about having a diagnostic done, but that seems like a waste of money if the check engine light is not on....
 

·
Registered
Joined
·
35 Posts
Discussion Starter #3
I think I complied with all the stated requirements for the Stage 2 module - free flow intake (accomplished with the Rusty's air tube and 6x9 K&N filter), reduced backpressure exhaust (accomplished with the flowmaster 70 exhaust and 2.5" exhaust tubing), and the low temp stat (accomplished with the Jet low temp stat). If there are other requirements, Jet should post them on their site. I checked the computer for error codes and got none. I'll try the battery disconnect thing too - I have done it for shorter time periods trying to achieve the same result but not for an hour. Thanks for your suggestions!
 

·
Registered
Joined
·
19 Posts
I'm with Travis on this one. Try to reset the stock PCM and start over.
Good luck.
 

·
Registered
Joined
·
24 Posts
On my WJ, I disconnected the negative battery cable for 10-15 minutes and it reset the ECU, and set my clock back to 12:00, this is what I follwed when I installed my Jet Stage II module.

A few thoughts:
1) Make sure you installed the Jet Chip into the correct spot on the ECU and it is seated and the harness is plugged back in and seated into the Jet Chip securely.
2) The performance gains (throttle responsiveness, acceleration) should be noticeable almost immediately.
3) Call Jet and tell them the issues you are having and have them walk you thru what might be wrong, if that still doesn't fix it tell them you want to send it back.

It wouldn't hurt to add a new set of plugs at the same time if it is close to the time where you would have changed them anyways.

Good luck :thumbsup:
 

·
Registered
Joined
·
9 Posts
I have never heard a good thing about any jet products in the Jeeps. Why do people still buy them? In the case that you have not read any previous complaints about the Jet product, I retract my assault.
 
1 - 6 of 6 Posts
Top