Jeep Grand Cherokee Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
about 3 months ago, i got a completely new a500 trasmission. i noticed problems on the first drive, it would hit the rev limiter between 2nd and 3rd gears under med. to hard acceleration. and some days even out of 1st gear. also it was unusual that it didnt shift out of 2nd till about 70-75 mph. after shifting into third you could only barely accelerate , if i gave it anny throttle at all, it instantly reved and redlined. ive dealt with this by just taking it easy and almost shifting "manually" but it gets even better.....yesterday i was going to istall my new speakers and at a red light my speakers fell and knoked the shifter into nuetral, so the light turned green i hit the gas and realized what happened, so i basically did an accidental "nuetral drop" the tires chirped and i took off hard, but there was no grinding or breaking sound so i wasnt very concerned. on my way home i noticed something different, there was a slight knock upon startup and when i put it in drive, it wouldnt shift out of first and was acting like low gear.the warranty is still good on the tranny but still any info as to why the tranny was messed up in the first place or why it is stuck in low gear would be very helpful!!
 

·
Registered
Joined
·
74 Posts
A 97 5.2ltr uses the 44RE. Not an a500. (yes I know they are almost one in the same) Regardless the first things I would check is the TV cable, and if the shift linkage is adjusted correctly. The TV cable tells the trans how much throtle is being applied, and if it is mis adjusted the trans will think you are getting into it much more than you really are.
 
1 - 4 of 4 Posts
Top