Jeep Grand Cherokee Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
I have a 93 grand limited 5.2 and I am having a couple problems with it that are confusing me.

1. I go start my zj in the morning to go to work it runs fantastic, I have a 20 minute drive to work she warms up before I get out of town. Then the problems start. I'll be driving and it'll cut out often(not misfire) then it stalls and I have to pull over wait a couple minutes and it starts right up no problem. This happens often but not every time I drive it. Wtf is going on with it. On to problem no. 2

2. If I drive for long periods of time(over an hour) the check engine light comes on and I get codes 51 & 52(to rich and to lean). I keep driving after the cel comes on and on light throttle it pulses. Also when I let off the throttle completely it jerks but only when the cel light is on.

Ok a side note before the cell light comes on I get good mpg 18ish hwy and after the cell does come on I get about 8mpg hwy

If you guys have any suggestions on what it is or where to begin that would be amazing.

I already did plugs and wires cap and rotor
 

·
Registered
Joined
·
74 Posts
My 93 was acting up as well

It was the fuel pump

We where sure for my zj
and replace it all back to normal then

I have no clue if there is a check procedure for the fuel pump
 

·
Registered
Joined
·
91 Posts
Figured it out yet???

I've got the same set-up: 93/5.2/46RH/249, etc. Anyway, my ZJ did the same thing and it turned out to be the fuel pump-this after swapping out 2 filters. Also, might want to check the reg. Good Luck!
 
1 - 4 of 4 Posts
Top