Jeep Grand Cherokee Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Went to replace factory radio bought all the kits and could not get radio to work so I put the factory one back in and now it won't work!
Worked fine an hour before!
Checked fuse ( 30 amp under dash) and though not blown I replaced anyway. Still no juice to radio. Any ideas?
 

·
Registered
Joined
·
17 Posts
Discussion Starter #2
so does anyone know exactly what fuse inside is for the audio?
one place says the thirty amp that I changed and then another source claims its a twenty amp.
problem is the twenty amp source says location is located on inside of fuse box cover there is none on my inside fuse box cover. Any help appreciated!
 

·
Registered
Joined
·
17 Posts
Discussion Starter #4
Did you check under your driver side dash for fuses? Should be near the hood release pull.
Yes thats where the 30 amp fuse is located and I changed it though the first one looked good.
Must be something before that.
Going to buy a tester today and try and find where the fire ends. Can’t blame aftermarket radio cause the original stock radio doesn’t work now!
Hoping someone had solved the problem before !! Lol
Any info or ideas??!!
 

·
Registered
Joined
·
38 Posts
You used a plug adapter kit?
Perhaps you got one of the wires mixed up?
Earlier GCs had two fuses, one to power the radio and one for memory voltage.
Possible a third for any amplifer if you have premium sound.
Check on google again for fuse locations for what radio package your GC has.
Good luck
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
Yes I used a kit and talked with service many times! lol
upon testing I found that the 30 amp fuse is hot!
still no power to the Radio power wire at original power wire!
harness had not be messed with so Im a Little confused !
 

·
Registered
Joined
·
10 Posts
You used a plug adapter kit?
Perhaps you got one of the wires mixed up?
Earlier GCs had two fuses, one to power the radio and one for memory voltage.
Possible a third for any amplifer if you have premium sound.
Check on google again for fuse locations for what radio package your GC has.
Good luck
 

·
Registered
Joined
·
10 Posts
No matter how well the radio is connected, if the speakers were not reconnected properly could be causing the problem.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #9
Thanks but I was on phone with support as I wired the speakers? They are correct! thanks again
 

·
Registered
Joined
·
17 Posts
Discussion Starter #11
Did you check this youtube video?
Thanks it brought out the question...
If you have the 30 amp fuse does it mean you have an amp?
I haven’t been able to see an amp and since I thought I had the basic radio, no steering wheel option and no satellite when original was working!
Will check all again.
thanks for your interest and input!
 

·
Registered
2015 Jeep Grand Cherokee WJ / 2010 JEEP JK
Joined
·
5 Posts
so does anyone know exactly what fuse inside is for the audio?

one place says the thirty amp that I changed and then another source claims its a twenty amp.

problem is the twenty amp source says location is located on inside of fuse box cover there is none on my inside fuse box cover. Any help appreciated!


For more information about car stereo please visit the website here https://www.walkermcguire.com/best-car-stereo-under-100-and-under-200
Why does my radio not work after changing battery?
 

·
Registered
Joined
·
38 Posts
Why does my radio not work after changing battery?
Here is a URL for Jeep TSBs problems and solutions. Hope this helps. Others have said you could try disconnecting the negative battery terminal to set if the radio resets but that's risky if you have an electronic throttle body.
 
1 - 14 of 14 Posts
Top