Jeep Grand Cherokee Forum banner
1 - 5 of 5 Posts

· Registered
2005 jeep grand Cherokee AWD 5.7l
Joined
·
1 Posts
Discussion Starter · #1 ·
2005 jeep grand Cherokee AWD 5.7l quadra trac 2 limited

So we have owned this jeep over a year. It's been a good jeep till the clicking started. We replaced the CV axles. Clicking kind of went away. And then it started back up. It don't matter if your on the gas or just letting the jeep roll. You hear this god awful click click click sound. Sometimes you get a random snap crack and pop. Don't matter if you turn, go straight, backwards or forward. Constantly clicking. The front end has some bushing that are wore out. We're gonna try to replace those and see if it fixes the front end movement. What y'all think?
Tire Land vehicle Vehicle Car Wheel
 

· Administrator
1996 ZJ 4.0 Limited and 2004 WJ 4.0
Joined
·
686 Posts
Try checking front prop shaft/drive shaft between transfer box and front axle as most likely one of the CV joints has run low on grease.
On my 2004 4.0 I normally just peel the boot back and apply some CV grease and clip the boot back on and soon sounds good until it dries up again, and seems to effect the front joint by the downpipe :)
 

· Registered
Joined
·
2 Posts
2005 jeep grand Cherokee AWD 5.7l quadra trac 2 limited

So we have owned this jeep over a year. It's been a good jeep till the clicking started. We replaced the CV axles. Clicking kind of went away. And then it started back up. It don't matter if your on the gas or just letting the jeep roll. You hear this god awful click click click sound. Sometimes you get a random snap crack and pop. Don't matter if you turn, go straight, backwards or forward. Constantly clicking. The front end has some bushing that are wore out. We're gonna try to replace those and see if it fixes the front end movement. What y'all think? View attachment 13534
I literally just joined this forum to post the exact same problem! Replaced ball joints, tie rod/drag link ends, shocks, click click click click click when I go below about 10mph. Front driveshaft?
 

· Administrator
1996 ZJ 4.0 Limited and 2004 WJ 4.0
Joined
·
686 Posts
I literally just joined this forum to post the exact same problem! Replaced ball joints, tie rod/drag link ends, shocks, click click click click click when I go below about 10mph. Front driveshaft?
Would be checking the front shaft between transfer and the axle to eliminate it from being the problem, and front shaft failure is fairly well known on some UK models.
 

· Registered
2001 WJ 4.0L, 157,000mi
Joined
·
20 Posts
I literally just joined this forum to post the exact same problem! Replaced ball joints, tie rod/drag link ends, shocks, click click click click click when I go below about 10mph. Front driveshaft?
I agree with Brian’s excellent post, check the front shaft for adequate grease, free play/wear.
 
1 - 5 of 5 Posts
Top