Jeep Grand Cherokee Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
i have 93 gc 4.0 aw4, strictly used for offroad. new years day we went out wheeling, wheeled for about 2.5 hrs, i got into some deep water, got stuck and broke an axle shaft at the same time. knew i was stuck, but i did the forward reverse thing a few times. knew it wouldnt help me. no big deal. anyway got pulled out, was trying to get rig back to trailer all of a sudden the jeep didnt want to move. kinda like it was stuck in 2nd maybe 3rd gear. i got it back to the trailer parked it, let it set about 10 mins checked the fluid, looked a little dark. started the jeep to pull up on trailer, everything is back to normal. i got the rig home, pulled the pan changed filter and fluid. completely flushed fluid until i had all new fluid in it. finally took it back out over the weekend, did awesome for around 3 hrs. i got down in some mud and had to do the forward reverse thing. took about 4 tries, only giving it enough to get the wheels spinning. i was not wide open or anything. nothing that would make the trans get hot. took maybe 4 mins to get out of it. i got out of it, went to climb a hill and it did the exact same thing. its like it was stuck in 2nd or 3rd gear. i pulled back over to the trailer loaded it up, went home and it was back to normal. someone help me out where do i start? its got me pulling my hair out. i would think if the trans was done for, it wouldnt last for 3hrs? the first day it was like 35 degrees out and this time it was like 75 degrees. It seems to do it when i go forward/reverse multiple times. thanks, sorry for the long first post.
 
1 - 1 of 1 Posts
Top