Jeep Grand Cherokee Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hey everyone! New to the forum, came for a little tech advice. I just bought a non-running 97 Orvis. PO claimed fuel pump, so I'm under it and notice the harness to the fuel pump is brand new. Grabbed my meter and I'm not seeing voltage with the key on, but I'm not sure what voltage I should be looking for under a key in run position condition.

Can anyone point me in the right direction for what voltages I should be looking for?

Also, worth noting, fuel gauge is nonoperational, so leads me to believe there's a wiring issue
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
To add to the diagnosis, with the key in the run position, the fuel pump relay doesn't click when plugged and unplugged. Neither does it click when the key is cycled from off to run
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Ok, did a little more digging, and jumping pin 30 and 87 with the relay removed runs the fuel pump, but the engine still will not fire.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4 (Edited)
Alright, so one more update that might tell someone more knowledgeable than me something.

I've got the body status display under the radio, that's not working. Overhead console, turn signals, fuel pump, all not working. Obd scanner gets power, but won't connect to pcm. The signs are leading me to either ignition or bcm.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #6
Got new ECU in the mail today, it fired right up. Thanks for being the only reply lol was hoping this forum would be a little more helpful but I think I'll stick with fb pages
 
1 - 6 of 6 Posts
Top