Jeep Grand Cherokee Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
I need help. Alarm is is disabled and immobilizer [ASD] is activated and I can't reset it.

History: 1999 Jeep Grand Cherokee Limited 4.7L 4x4
I drove to a store and it wouldnt start again. Single click. Was told it was starter. Got towed home. Replaced starter. Got same click. Got a jump. Fired up and I drove it to charge battery. Turned off, same click. Replaced battery with new. Same click. Checked fuses. A friend did a test by jumping fuses to recreate the click. Cleaned battery cables. She fired up but shut off after 5 seconds. The ASD was engaged by jumping the fuses.

Current Symptoms: No alarm light on top of dash. Instrument panel gauges don't work. Skim light WAS on, but I tried a procedure of leaving key in to on position for 10 minutes in hopes of reset. Now it just comes on AFTER I start her and she turns off. Then its not on when I turn key off and then back to on position. Key fob panic button does not work. Key fob lock and unlock buttons lock every door but driver door. Lock button does not activate alarm.

NOTHING weird was done other than jumping fuses to get the click, checking for power. [it was never the starter or battery, even though battery was bad. It was just the cables corrosion.]

Ive tried 4 different reset options I found online and nothing worked. Though I don't know if it was for a 1999.

There has to be a way to activate the alarm and reset the ASD/Immobilizer.
I gave history detail to help. I am NOT wanting to bypass. Everything was working fine before. I've already spent $500 for no reason, except new battery. I'm disabled and on SSDI and just can't afford anymore.

I'm thinking if I can get the ALARM working, which would then maybe have my key fob working properly, I could reset the ASD. I have no clue. I'm not a mechanic or electrician. But this isn't an airbag that needs to be replaced after activation.
This is my only transportation and I've been down since Dec31.

Michael

UPDATE
I just tried the panic button by pressing and holding and the lights flashed, horn honking. Had to insert key into ignition to stop it. Still wont stay running though.
 

·
Registered
Joined
·
144 Posts
I'm glad you're already looking at corroded battery cables because thats what this sounds like to me...an open or weak connection in the main power circuit. Closely examine every cable and connector in the battery/alternator/main fuse box circuit.
 
1 - 2 of 2 Posts
Top