throttle valve(TV) cable adjustment - North American Grand Cherokee Association
North American Grand Cherokee Association

Go Back   North American Grand Cherokee Association > Grand Cherokee Forum > Jeep Grand Cherokee Lounge-ZJ/WJ
Nagca.com is the premier Jeep Grand Cherokee Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Display Modes
Old 06-27-2010, 01:25 PM   #1
ilive4cars0122
Senior Member
Grand Junkie
 
Join Date: Mar 2010
Posts: 127
Default throttle valve(TV) cable adjustment

recently i've been looking into adjusting the throttle valve cable before going and replacing the gov pressure sensor and selenoid in the tranny of my 98 5.9 zj...i read the haynes repair manual and the procedure but to me it is very unclear still... has anyone done this before and have any help for me?
ilive4cars0122 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-28-2010, 05:23 PM   #2
jeeptech
Member
Grand Rookie
 
Join Date: Jun 2010
Location: Milford, NH
Posts: 35
Default

There should be about a 1/16" gap between the plastic end and the cable end crimp at the throttle body linkage. You check this with the engine off and throttle closed. If this is not correct then you have to lift the lock clip and slide the cable housing until this distance is correct.
jeeptech is offline   Reply With Quote
Old 06-28-2010, 07:16 PM   #3
ilive4cars0122
Senior Member
Grand Junkie
 
Join Date: Mar 2010
Posts: 127
Default

i broke the plastic end to the cable where it attaches to the throttle i suppose u wouldn't know if generally the cables are all the same... if i could take it off a 4.0 engine where it is side mounted and the throttle is over farther than on my 5.9 where it is rear mounted?
ilive4cars0122 is offline   Reply With Quote
Old 06-29-2010, 03:03 AM   #4
jeeptech
Member
Grand Rookie
 
Join Date: Jun 2010
Location: Milford, NH
Posts: 35
Default

I don't know, But I may have a 4.0 cable kicking around I could measure and let you know.
jeeptech is offline   Reply With Quote
Old 06-29-2010, 08:04 AM   #5
ilive4cars0122
Senior Member
Grand Junkie
 
Join Date: Mar 2010
Posts: 127
Default

well i just ordered one from the dealership $54 and three days to get here but that sucks with the 4th coming up and needing to drive it...u have any ideas on a temporary 3 day fix besides mayvbe glueing it on or something haha
ilive4cars0122 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:42 PM.



Powered by vBulletin® Copyright ©2000 - 2014, vBulletin Solutions, Inc.